EIDO Healthcare - Download Centre is unavailable – Incident details

Download Centre is unavailable

Resolved
Major outage
Started over 1 year agoLasted 22 minutes

Affected

Inform PDF Download Centre

Major outage from 10:08 AM to 10:30 AM

London

Major outage from 10:08 AM to 10:30 AM

Australia

Major outage from 10:08 AM to 10:30 AM

Canada

Major outage from 10:08 AM to 10:30 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    We are currently monitoring the result of the fix.

  • Identified
    Identified

    We've identified the issue and have rolled out a fix.

  • Investigating
    Investigating

    We are currently investigating this incident.