[Resolved] Issues with Colorectal document downloads

Started on January 15, 2021 at 10:31:00 AM GMT+0. Resolved after 4 days

Affected

Europe
Asia Pacific
North America
  • Investigating
    January 15, 2021 at 10:31:00 AM GMT+0

    We are currently investigating this incident.

  • Monitoring
    January 15, 2021 at 1:26:33 PM GMT+0

    We have restored an earlier backup and are monitoring.

  • Resolved
    January 19, 2021 at 8:16:46 AM GMT+0

    All document downloads are now working again