[Resolved] Download centre is down

Started on February 15, 2021 at 9:10:24 AM GMT+0. Resolved after about 1 hour

Affected

Europe
North America
  • Investigating
    February 15, 2021 at 9:10:24 AM GMT+0

    We are currently investigating this incident.

  • Identified
    February 15, 2021 at 9:12:02 AM GMT+0

    There was an issue with the database which has been identified, we are rolling back to a know working backup now

  • Monitoring
    February 15, 2021 at 9:14:46 AM GMT+0

    We implemented a fix and currently monitoring the result.

  • Identified
    February 15, 2021 at 9:28:56 AM GMT+0

    Hot fix has was not successful, rolling back to a previous version

  • Monitoring
    February 15, 2021 at 10:09:59 AM GMT+0

    We implemented a fix and currently monitoring the result.

  • Resolved
    February 15, 2021 at 10:17:02 AM GMT+0

    New backup restore has resolved the issues.