[Resolved] Login issues affecting Europe and Americas

Started on May 24, 2021 at 9:21:06 AM GMT+0. Resolved after about 1 hour

Affected

Europe
North America
  • Investigating
    May 24, 2021 at 9:21:06 AM GMT+0

    We are currently investigating this incident.

  • Monitoring
    May 24, 2021 at 9:50:10 AM GMT+0

    We've implemented a fix and currently monitoring the result. There is an issue with bilingual documents which is yet to be resolved, but general service is now restored.

  • Resolved
    May 24, 2021 at 10:07:47 AM GMT+0

    Login issue has been resolved. We will separate the bilingual download issue into an incident of it's own for visibility