[Resolved] Service outage

Started on May 27, 2021 at 3:19:11 PM GMT+0. Resolved after 34 minutes

Affected

Europe
North America
  • Investigating
    May 27, 2021 at 3:19:11 PM GMT+0

    We are currently investigating this incident.

  • Identified
    May 27, 2021 at 3:27:10 PM GMT+0

    We've identified the cause and are working on a resolution.

  • Monitoring
    May 27, 2021 at 3:41:24 PM GMT+0

    We implemented a fix and currently monitoring the result.

  • Resolved
    May 27, 2021 at 3:53:24 PM GMT+0

    Service restored