[Resolved] Intermittent website outages

Started on June 10, 2021 at 8:18:39 AM GMT+0. Resolved after about 3 hours

Affected

EIDO Corporate Website
  • Investigating
    June 10, 2021 at 8:18:39 AM GMT+0

    We are currently investigating this incident.

  • Resolved
    June 10, 2021 at 11:03:29 AM GMT+0

    Issues with hosting provider have been resolved.