Some customers unable to access documents in the UAE

Resolved
Partial outage
Started almost 2 years ago Lasted about 1 hour

Affected

Inform PDF Download Centre
London
Australia
Updates
  • Resolved
    Resolved

    This issue has been resolved

  • Monitoring
    Monitoring

    We've identified the cause of the issue and have implemented a fix.

  • Investigating
    Investigating

    We are currently investigating this incident