Consent forms loading slowly

Resolved
Degraded performance
Started 10 months ago Lasted 6 days

Affected

Inform Consent Suite
London
Australia
Updates
  • Resolved
    Resolved

    A patch has been released to improve the load time.

  • Investigating
    Investigating

    Some users may experience a slow response when starting a consent form via the dashboard. The consent form will load eventually and can still be completed.

    Our team are investigating the source of this issue and will update with more information.