EIDO Healthcare - Intermittent "site cannot be reached" bug affecting some Chrome and Edge users – Incident details

Intermittent "site cannot be reached" bug affecting some Chrome and Edge users

Resolved
Degraded performance
Started 19 days agoLasted 5 days

Affected

Inform Consent Suite

Degraded performance from 8:32 AM to 8:42 AM

London

Degraded performance from 8:32 AM to 8:42 AM

India

Degraded performance from 8:32 AM to 8:42 AM

Australia

Degraded performance from 8:32 AM to 8:42 AM

Updates
  • Resolved
    Resolved

    This issue has now been resolved. Any customers still experiencing the issue are advised to clear their browser cache to ensure the latest version of the application is loaded, and clear the URL path one final time by visiting the links below:

  • Identified
    Identified

    We have identified an intermittent issue affecting some users on the Google Chrome or Microsoft Edge browsers where the site returns a "Site cannot be reached" or "Having trouble loading this page" error.

    The current workaround for this issue is to head directly to "https://uk.eidodigital.com" (UK customers), "https://australia.eidodigital.com" (Australia customers), or "https://india.eidodigital.com" (India customers) but we are prioritising a resolution.