[Resolved] Download centre failing to load procedures

Started on March 1, 2021 at 9:00:49 AM GMT+0. Resolved after 28 minutes

Affected

Europe
  • Investigating
    March 1, 2021 at 9:00:49 AM GMT+0

    We are currently investigating this incident.

  • Identified
    March 1, 2021 at 9:09:27 AM GMT+0

    We have identified the issue and are working on a fix for this incident.

  • Monitoring
    March 1, 2021 at 9:18:59 AM GMT+0

    We implemented a fix and currently monitoring the result.

  • Resolved
    March 1, 2021 at 9:28:23 AM GMT+0

    Issue causing the outage has been resolved.