EIDO Healthcare - Missing laterality option for some lateral procedures – Incident details

Missing laterality option for some lateral procedures

Resolved
Degraded performance
Started 24 days agoLasted about 23 hours

Affected

Inform Consent Suite

Degraded performance from 3:35 PM to 2:41 PM

London

Degraded performance from 3:35 PM to 2:41 PM

Updates
  • Resolved
    Resolved

    This issue has been resolved. Any customers who are still seeing issues please log out of the dashboard and back in to pull the latest procedure list.

  • Identified
    Identified

    We've identified the cause of the issue and are working on a fix.

  • Investigating
    Investigating

    We are currently investigating this incident.