EIDO Healthcare - Email Delivery Disruption – Incident details

Email Delivery Disruption

Monitoring
Major outage
Started 5 days ago

Affected

Digital Consent

Degraded performance from 10:14 AM to 12:00 AM

London

Degraded performance from 10:14 AM to 12:00 AM

Australia

Degraded performance from 10:14 AM to 12:00 AM

Updates
  • Monitoring
    Monitoring

    The issue affecting email delivery has now been resolved. Our email provider has implemented a fix, and all services are operating as normal. We are monitoring the system performance and are planning a deployment later in the week to improve reliability in this area.

    Thank you for your patience while we worked to resolve this issue.

  • Identified
    Identified

    We are continuing to work on a fix for this incident.
    The email provider are investigating.

  • Investigating
    Investigating

    We are currently experiencing an issue with email delivery. This is affecting one-time passcodes, password reset emails, and patient communication links.

    As a workaround, please use SMS where available.

    We are investigating the issue with our provider and will provide updates as soon as possible.